Kysymys:
Turvallinen alustojen välinen pikaviestintäohjelmisto
Olli
2014-02-05 07:30:36 UTC
view on stackexchange narkive permalink

Mikä on turvallista - kuten viestien sisällön luottamuksellisuudessa - pikaviestintäohjelmisto, jolla on ainakin seuraavat ominaisuudet:

  • Oma palvelin ei ole asennettava (ja ylläpidettävä)
  • Windows-, OS X- ja Linux-tuki
  • Päättävä salaus estää viestien kuuntelun palvelimella
  • Henkilökohtaiset ja ryhmäkeskustelut
Kolme vastused:
#1
+8
unor
2014-02-05 07:49:56 UTC
view on stackexchange narkive permalink

Voit käyttää mitä tahansa XMPP-asiakasta, joka tukee OpenPGP tai OTR. Joten jokainen henkilö voisi käyttää valitsemaansa asiakasta, eikä kaikkien tarvitse käyttää samaa.

Mutta jos samaa asiakasta tulisi käyttää eri alustoilla, katso Jitsi (lisenssi: LGPL), joka käyttää Java-sovellusta. Se tukee OTR: tä. Katso tämä (vanha) video: ensimmäinen OTR-tekstikeskustelusi Jitsin kanssa.

(XMPP toimii, kuten sähköposti, ei vain tietyn palveluntarjoajan kanssa. Joten voit tehdä valintasi palveluntarjoaja käyttää, ja jokainen voi taas käyttää eri palvelua. Esimerkiksi @ jabber.org, @ dukgo.com, @ gmx.com,…)

Mielestäni on hyvä käyttää eri ohjelmistoja eri alustoilla, kunhan ne ovat yhteensopivia. Mutta Jitsi näyttää sopivan melko hyvin.
Aiheeseen liittyvä kysymys: [Mitkä XMPP-asiakkaat tukevat OpenPGP: tä (XEP-0027)?] (Http://softwarerecs.stackexchange.com/q/235/60)
+1 XMPP: n ja OTR: n pitäisi kattaa tarve todella hyvin, käytän niitä itse päivittäin.
Heitän sisään http://www.pidgin.im. Saatavana kaikkiin käyttöjärjestelmiin ja valmiiksi pakattu useimpiin jakeluihin.
OTR on hieno keskusteluihin, mutta se ei tue ryhmäkeskustelua, joka oli yksi OP: n asettamista vaatimuksista. Viime vuosien aikana on puhuttu huomattavasti * monipuolisesta OTR: stä * (lyhyt mpOTR), mutta sikäli kuin tiedän toistaiseksi, he eivät ole vielä panostaneet.
#2
+7
Seth
2014-02-20 22:31:39 UTC
view on stackexchange narkive permalink

Voit kokeilla uutta salattua pikaviestiohjelmaa Tox. Se on alfa-vaiheessa, mutta chat-ominaisuus näyttää toimivan melko hyvin.

Siinä on kaikki haluamasi ominaisuudet:

  • Yksi viestit ja ryhmäkeskustelut.

  • Se salaa viestit.

  • Tukee Mac OSX: ää, Windowsia ja Linuxia.

  • Asennusta ei tarvita.

Venom UI

Kuten aiemmin mainittiin, ohjelmisto on edelleen alfa-tilassa, mutta mielestäni se osoittaa paljon lupauksia.

Onko se edelleen alfa-tilassa?
Ei, se ei ole enää alfa-tilassa.
#3
+5
Seth
2014-02-05 07:55:34 UTC
view on stackexchange narkive permalink

Voit käyttää Cryptocat -selainlaajennusta salattuun keskusteluun (samanlainen kuin IRC, mutta turvallisempi;)

Cryptocat tukee kaikkia tärkeimpiä selaimia, mukaan lukien:

  • Chrom (e) (ium)

  • Firefox

  • Safari

  • Opera

  • OSX Apple App Storen kautta.

Cryptocat UI

Yksi vaatimuksista on "oman palvelimen ei tarvitse asentaa (eikä ylläpitää)". Onko julkisia Cryptocat-palvelimia?
@Gilles Kyllä, on olemassa julkisia Cryptocat-palvelimia, joihin pääsee selainlaajennusten ja -sovellusten kautta. [Tässä heidän verkkomonitori] (https://crypto.cat/monitor/) (kolmansien osapuolten kryptaatioverkot eivät sisälly). BTW: [Cryptocatin verkko sijaitsee osoitteessa * "Bahnhof" *] (https://blog.crypto.cat/2013/02/cryptocat-network-now-in-swedish-nuclear-bunker/) (ruotsalainen verkkopalvelin, tunnettu isäntänä * WikiLeaks * ja * The Pirate Bay *).
Nopea päivitys: Cryptocat ei ole ollut käytettävissä helmikuusta 2015 lähtien tekijän ajanpuutteen vuoksi. Viestissä [crypto.cat] (https://crypto.cat/) hän mainitsee Cryptocat-ohjelmiston täydellisen uudelleenkirjoituksen, mutta on epäselvää, onko / milloin tämä on saatavilla.


Tämä Q & A käännettiin automaattisesti englanniksi.Alkuperäinen sisältö on saatavilla stackexchange-palvelussa, jota kiitämme cc by-sa 3.0-lisenssistä, jolla sitä jaetaan.
Loading...